DreamPi, PSO, disconnection and lost save file

Online games, how to get online, and anything involving Dreamcast online can be discussed here.
User avatar
Aleron Ives
Uber
Posts: 1037
Contact:

Re: DreamPi, PSO, disconnection and lost save file

Post#21 » Sat Sep 08, 2018 7:19 am

To be fair, using real dial-up to an ISP is much more reliable than klouging a fake dial-up ISP to your LAN.

That's useful information for comparing against other people who've been FATmared, at least.
"Fear the HUnewearl."
Image

alix
shadow
Posts: 13

Re: DreamPi, PSO, disconnection and lost save file

Post#22 » Sat Sep 08, 2018 7:55 am

What I might try next time is power the Dreamcast off when it says “disconnected, press start to save and exit”. That might avoid the corrupted file issue? A bit of a pain but better than losing hours of play.

alix
shadow
Posts: 13

Re: DreamPi, PSO, disconnection and lost save file

Post#23 » Sat Sep 08, 2018 10:11 am

Nico0020 wrote:
alix wrote:
Aleron Ives wrote:The "fat HUmar" corruption means that your character's appearance got completely zeroed out, and a fat HUmar is the result of having all your character parameters at 0. We still have no idea what causes the bug, and it only seems to apply to Dreamcast, so it's possible there's nothing we can do to fix it through server modifications. If only we knew what triggered it, at least we might be able to warn people of what not to do. >_>;


Okay it's happened again so I thought I would share what I know.

I am getting terrible connection issues, I don't know why. It was working fine last night, and again this morning... but since lunchtime today, impossible to connect. I have tried rebooting the Pi, I have tried reusing a different Pi, I have tried with a direct Ethernet cable between the Pi and the router (rather than through my switch and wall adapter)... nothing works. This is what happens every time:

- I choose "continue game"
- I select my character
- I select "online"
- I select "yes" to the various questions.
- I arrive in the place where you can choose a ship
- I choose a ship (I can see people connected when pressing x)
- I choose a slot
- I get the loading screen
- Then as soon as I get to the lobby, I get an error message: The line was disconnected. Game Over. Press start to return to menu
- I press start, and it saves. I AM PRETTY SURE THIS IS WHEN THE FILE CAN GET CORRUPTED.

I did the above 4 or 5 times in a row, and eventually it corrupted my file. Please note it did take a few attempts. It was the same last time, I kept being disconnected and reconnected, and after a few times it corrupted the file.

Now, my character is backed-up in the cloud so hopefully I can restore it, but I can't for the life of me reconnect to the server. I have given up for now.

I think I might have connected long enough earlier to back up my corrupted character, if that's any help?

Any idea why I am getting such severe connection problems?

Cheers :)

Alix



This is exactly how that used to happen to me. I stated in another thread somewhere about it. Setting my routers MTU to 1400 kept it from happening again. But I'd assume countless other network problems could cause the disconnect. Seems like a damn miracle we all stayed online with 56K like this back in the day.


Still having connection issues. Or rather I can connect but it freezes when i create a team and try and start a quest... it freezes when it attempts to download to quest data to memory.

I have connected to my router and changed the MTU value to 1400... it was only 1500 though so not a massive difference.

Any other settings on the router I should be wary of?

Thanks :)

alix
shadow
Posts: 13

Re: DreamPi, PSO, disconnection and lost save file

Post#24 » Sun Sep 09, 2018 4:12 am

Please note that the MTU fix seems to have done the trick. I played online for a couple of hours last night and not a single glitch. It was awesome :)

  • Similar Topics
    Replies
    Views
    Last post

Return to “Online”

Who is online

Users browsing this forum: No registered users