DreamPi, PSO, disconnection and lost save file

Online games, how to get online, and anything involving Dreamcast online can be discussed here.
alix
shadow
Posts: 13

Re: DreamPi, PSO, disconnection and lost save file

Post#11 » Wed Sep 05, 2018 2:56 pm

Okay it's fine, I've done it, I've created a new character and back it up on the server.

Cool, thank you so much everyone.

I shall do some testing with the Ethernet cable next.

User avatar
BlueCrab
Developer
Posts: 757

Re: DreamPi, PSO, disconnection and lost save file

Post#12 » Wed Sep 05, 2018 3:05 pm

alix wrote:
pcwzrd13 wrote:Finally, there are several ways to back up your PSO character but the easiest would be to use the server backup feature. I have instructions here.


On more question regarding this.

On the page where you can register characters to be backed up, it says : "If you have already been on the server with this copy of the game, please use this alternate form to register your serial number and access key."

I have used a character on the server already, but it's the one that got corrupt. Do I still need to register with the Guildcard Number of my corrupt character?
Your guild card number shouldn't change just from making a new character -- as long as it's on the same Dreamcast and you haven't erased the flashrom in some way.

That said, it sounds like you've already gotten everything up and running. ;)

Kobra Kai
lithium
Posts: 40

Re: DreamPi, PSO, disconnection and lost save file

Post#13 » Wed Sep 05, 2018 3:19 pm

Im in same boat. I cant register my codes

alix
shadow
Posts: 13

Re: DreamPi, PSO, disconnection and lost save file

Post#14 » Wed Sep 05, 2018 4:36 pm

BlueCrab wrote:
alix wrote:
pcwzrd13 wrote:Finally, there are several ways to back up your PSO character but the easiest would be to use the server backup feature. I have instructions here.


On more question regarding this.

On the page where you can register characters to be backed up, it says : "If you have already been on the server with this copy of the game, please use this alternate form to register your serial number and access key."

I have used a character on the server already, but it's the one that got corrupt. Do I still need to register with the Guildcard Number of my corrupt character?
Your guild card number shouldn't change just from making a new character -- as long as it's on the same Dreamcast and you haven't erased the flashrom in some way.

That said, it sounds like you've already gotten everything up and running. ;)


Yes created a new character, got it to level 4 and saved it to the server. I can see it from the website, so it has worked. Thanks again to everyone, great community :)

User avatar
Aleron Ives
Uber
Posts: 1047
Contact:

Re: DreamPi, PSO, disconnection and lost save file

Post#15 » Wed Sep 05, 2018 8:20 pm

The "fat HUmar" corruption means that your character's appearance got completely zeroed out, and a fat HUmar is the result of having all your character parameters at 0. We still have no idea what causes the bug, and it only seems to apply to Dreamcast, so it's possible there's nothing we can do to fix it through server modifications. If only we knew what triggered it, at least we might be able to warn people of what not to do. >_>;
"Fear the HUnewearl."
Image

alix
shadow
Posts: 13

Re: DreamPi, PSO, disconnection and lost save file

Post#16 » Thu Sep 06, 2018 6:55 am

Aleron Ives wrote:The "fat HUmar" corruption means that your character's appearance got completely zeroed out, and a fat HUmar is the result of having all your character parameters at 0. We still have no idea what causes the bug, and it only seems to apply to Dreamcast, so it's possible there's nothing we can do to fix it through server modifications. If only we knew what triggered it, at least we might be able to warn people of what not to do. >_>;


Okay, it's not just me then.

The fact that i can now back my character up on the server really mitigates the problem!

Thanks for all the hard work! :)

alix
shadow
Posts: 13

Re: DreamPi, PSO, disconnection and lost save file

Post#17 » Thu Sep 06, 2018 6:57 am

By the way, I tried again last night, with my exact same set-up, in order to replicate the issue, so that I could then compare with the long Ethernet cable... (I am a software engineer after all!)

And it worked perfectly. I even played my first game with a guy called Leon. I didn't disconnect a single time, despite me still using the power socket adapter.

Strange. In a good way, but still :)

User avatar
BlueCrab
Developer
Posts: 757

Re: DreamPi, PSO, disconnection and lost save file

Post#18 » Thu Sep 06, 2018 8:18 am

alix wrote:By the way, I tried again last night, with my exact same set-up, in order to replicate the issue, so that I could then compare with the long Ethernet cable... (I am a software engineer after all!)

And it worked perfectly. I even played my first game with a guy called Leon. I didn't disconnect a single time, despite me still using the power socket adapter.

Strange. In a good way, but still :)
Transient electrical spikes on the power line can interfere with your powerline ethernet adapter in strange/unexpected ways. Basically, any electrical appliance in your house could potentially cause issues to occur randomly in the future too -- especially if your house has older wiring.

alix
shadow
Posts: 13

Re: DreamPi, PSO, disconnection and lost save file

Post#19 » Fri Sep 07, 2018 10:18 am

Aleron Ives wrote:The "fat HUmar" corruption means that your character's appearance got completely zeroed out, and a fat HUmar is the result of having all your character parameters at 0. We still have no idea what causes the bug, and it only seems to apply to Dreamcast, so it's possible there's nothing we can do to fix it through server modifications. If only we knew what triggered it, at least we might be able to warn people of what not to do. >_>;


Okay it's happened again so I thought I would share what I know.

I am getting terrible connection issues, I don't know why. It was working fine last night, and again this morning... but since lunchtime today, impossible to connect. I have tried rebooting the Pi, I have tried reusing a different Pi, I have tried with a direct Ethernet cable between the Pi and the router (rather than through my switch and wall adapter)... nothing works. This is what happens every time:

- I choose "continue game"
- I select my character
- I select "online"
- I select "yes" to the various questions.
- I arrive in the place where you can choose a ship
- I choose a ship (I can see people connected when pressing x)
- I choose a slot
- I get the loading screen
- Then as soon as I get to the lobby, I get an error message: The line was disconnected. Game Over. Press start to return to menu
- I press start, and it saves. I AM PRETTY SURE THIS IS WHEN THE FILE CAN GET CORRUPTED.

I did the above 4 or 5 times in a row, and eventually it corrupted my file. Please note it did take a few attempts. It was the same last time, I kept being disconnected and reconnected, and after a few times it corrupted the file.

Now, my character is backed-up in the cloud so hopefully I can restore it, but I can't for the life of me reconnect to the server. I have given up for now.

I think I might have connected long enough earlier to back up my corrupted character, if that's any help?

Any idea why I am getting such severe connection problems?

Cheers :)

Alix

User avatar
Nico0020
Dead House
Posts: 381

Re: DreamPi, PSO, disconnection and lost save file

Post#20 » Sat Sep 08, 2018 5:54 am

alix wrote:
Aleron Ives wrote:The "fat HUmar" corruption means that your character's appearance got completely zeroed out, and a fat HUmar is the result of having all your character parameters at 0. We still have no idea what causes the bug, and it only seems to apply to Dreamcast, so it's possible there's nothing we can do to fix it through server modifications. If only we knew what triggered it, at least we might be able to warn people of what not to do. >_>;


Okay it's happened again so I thought I would share what I know.

I am getting terrible connection issues, I don't know why. It was working fine last night, and again this morning... but since lunchtime today, impossible to connect. I have tried rebooting the Pi, I have tried reusing a different Pi, I have tried with a direct Ethernet cable between the Pi and the router (rather than through my switch and wall adapter)... nothing works. This is what happens every time:

- I choose "continue game"
- I select my character
- I select "online"
- I select "yes" to the various questions.
- I arrive in the place where you can choose a ship
- I choose a ship (I can see people connected when pressing x)
- I choose a slot
- I get the loading screen
- Then as soon as I get to the lobby, I get an error message: The line was disconnected. Game Over. Press start to return to menu
- I press start, and it saves. I AM PRETTY SURE THIS IS WHEN THE FILE CAN GET CORRUPTED.

I did the above 4 or 5 times in a row, and eventually it corrupted my file. Please note it did take a few attempts. It was the same last time, I kept being disconnected and reconnected, and after a few times it corrupted the file.

Now, my character is backed-up in the cloud so hopefully I can restore it, but I can't for the life of me reconnect to the server. I have given up for now.

I think I might have connected long enough earlier to back up my corrupted character, if that's any help?

Any idea why I am getting such severe connection problems?

Cheers :)

Alix



This is exactly how that used to happen to me. I stated in another thread somewhere about it. Setting my routers MTU to 1400 kept it from happening again. But I'd assume countless other network problems could cause the disconnect. Seems like a damn miracle we all stayed online with 56K like this back in the day.

  • Similar Topics
    Replies
    Views
    Last post

Return to “Online”

Who is online

Users browsing this forum: No registered users