Can't authenticate

Online games, how to get online, and anything involving Dreamcast online can be discussed here.
FlippyTheYoshi
shadow
Posts: 12

Can't authenticate

Post#1 » Sun Aug 11, 2019 6:01 pm

I moved my dreamcast setup to another room which has cable so I can use my dreampi via cable and not Wi-Fi, I did a fresh install of the OS and after setting everything up, I can't authenticate when attempting to play online.

On IGP, I manage to get past the dial dialogs, and when I try to log in with my user and password, it won't authenticate.

Tried with Quake 3 Arena as well, and when it comes to the final box to authenticate, the entire game freezes, but if I wait a minute or 2, it pops up a message saying that it couldn't authenticate with the server.

Tried using DMZ with the dreamcast's IP too, but no luck with that either.

I didn't touch any configs of the pi after installing the 1.7 version downloaded in DCLive's download page.

Any help would be greatly appreciated.

EDIT: I went back and used Wi-Fi again instead of cable and everything works fine. I'm still looking to play with cable so if anyone got a clue to fix it I'd be thankful of it

EDIT 2: I tried connecting the pi with a different cable but still no luck, so my final guess is that there's a config in my router settings that isn't allowing me to authenticate.

EDIT 3: I did a factory reset on the router but it still won't authorize me to play.
Last edited by FlippyTheYoshi on Mon Aug 26, 2019 10:50 am, edited 2 times in total.

User avatar
poopidoop
core
Posts: 127

Re: Can't authenticate

Post#2 » Sun Aug 11, 2019 8:56 pm

did you ever try doind a new 1.7 image on ur sd card, i was wondering if because you had it set up for wifi maybe its making it so you cant go back to wired connection

FlippyTheYoshi
shadow
Posts: 12

Re: Can't authenticate

Post#3 » Mon Aug 12, 2019 7:57 am

poopidoop wrote:did you ever try doind a new 1.7 image on ur sd card, i was wondering if because you had it set up for wifi maybe its making it so you cant go back to wired connection


Yeah, I did a brand new 1.7 install on the SD card that I use, even after seeing everything fail with cable, I used a different SD card to test but no luck

User avatar
Xiden
Super Sonic
Posts: 1566

Re: Can't authenticate

Post#4 » Mon Aug 12, 2019 9:20 am

FlippyTheYoshi wrote:
poopidoop wrote:did you ever try doind a new 1.7 image on ur sd card, i was wondering if because you had it set up for wifi maybe its making it so you cant go back to wired connection


Yeah, I did a brand new 1.7 install on the SD card that I use, even after seeing everything fail with cable, I used a different SD card to test but no luck


have you tried using a different cable? Curious if the cable itself is bad.

FlippyTheYoshi
shadow
Posts: 12

Re: Can't authenticate

Post#5 » Mon Aug 12, 2019 9:32 am

Xiden wrote:
FlippyTheYoshi wrote:
poopidoop wrote:did you ever try doind a new 1.7 image on ur sd card, i was wondering if because you had it set up for wifi maybe its making it so you cant go back to wired connection


Yeah, I did a brand new 1.7 install on the SD card that I use, even after seeing everything fail with cable, I used a different SD card to test but no luck


have you tried using a different cable? Curious if the cable itself is bad.


No I haven't, but I used the same cable with 2 different laptops and it's working fine like it should, so I'm guessing it isn't the cable's fault.

FlippyTheYoshi
shadow
Posts: 12

Re: Can't authenticate

Post#6 » Sun Aug 25, 2019 8:01 pm

Update: I've tried to connect the raspberry with a different cable this time, but no luck at all.

I even tried setting up a new access point in the same room as my DC & raspberry, and even if it's connecting via Wi-Fi, it still won't work.

My final guess is that there's a config on my router page that isn't allowing me to authenticate.

Any help would be appreciated.

User avatar
Xiden
Super Sonic
Posts: 1566

Re: Can't authenticate

Post#7 » Sun Aug 25, 2019 11:19 pm

FlippyTheYoshi wrote:Update: I've tried to connect the raspberry with a different cable this time, but no luck at all.

I even tried setting up a new access point in the same room as my DC & raspberry, and even if it's connecting via Wi-Fi, it still won't work.

My final guess is that there's a config on my router page that isn't allowing me to authenticate.

Any help would be appreciated.


What kind of router are u using? I'd suggest maybe factory resetting the router if its not too much trouble. Maybe you have a certain setting that's blocking packets. Just my guess though.

FlippyTheYoshi
shadow
Posts: 12

Re: Can't authenticate

Post#8 » Mon Aug 26, 2019 5:49 am

Xiden wrote:
FlippyTheYoshi wrote:Update: I've tried to connect the raspberry with a different cable this time, but no luck at all.

I even tried setting up a new access point in the same room as my DC & raspberry, and even if it's connecting via Wi-Fi, it still won't work.

My final guess is that there's a config on my router page that isn't allowing me to authenticate.

Any help would be appreciated.


What kind of router are u using? I'd suggest maybe factory resetting the router if its not too much trouble. Maybe you have a certain setting that's blocking packets. Just my guess though.


It is a technicolor TC7210.MTA

And I suppose I can do a factory reset if it solves the issue, I'll try to do it today and update the post with the results.

FlippyTheYoshi
shadow
Posts: 12

Re: Can't authenticate

Post#9 » Mon Aug 26, 2019 10:49 am

Update: After doing a factory reset, it still won't authorize me, but still works via Wi-Fi.

So now all my options are gone, I'll gladly take anyone's guesses, really, I just want this to work properly.

Thanks in advance.

anti
shadow
Posts: 13

Re: Can't authenticate

Post#10 » Tue Sep 10, 2019 6:47 pm

It's possible that you're behind a double NAT or that you're doing the port forwarding/DMZ incorrect.

Try enabling UPnP on the router and see if it establishes connectivity. It appears your router has that functionality as per this page:
https://setuprouter.com/router/technico ... -large.htm

Return to “Online”

Who is online

Users browsing this forum: No registered users