Page 1 of 1

PSO Quest Freeze Issue

Posted: Wed Feb 05, 2020 7:59 am
by kiktuo
Hello all,

I have tried both PSO and PSOv2 and while i can get online and create a team fine when i try to launch a quest it says that it is being loaded into memory and crashed my system.

Has anyone encountered this and know of a fix?


Re: PSO Quest Freeze Issue

Posted: Wed Feb 05, 2020 9:33 am
by Nico0020
This is an MTU issue. In your router, set your MTU to like 1400( IIRC ) and you should be fine.

Sent from my Pixel 3a using Tapatalk

Re: PSO Quest Freeze Issue

Posted: Mon May 04, 2020 7:51 pm
by Joashwa

I've had the same issue today. Felt a sudden urge to play PSOV2. So I unpacked the dreampi, updated the software, hooked it all up to the Dreamcast.

Things went quite smoothly after some faffing around with WI-FI settings, I got online with PSO, no issues whatsoever.

Then I started trying to download some quests. The game froze and the music would stutter.

I had a play around, reset the console a few times, tried a few other quests on different ships. Read some advice online given to people who had a similar issue. I've cleaned the laser, wiped the disc, tested the retail disc (PAL) and the patched version (NTSC?). I've changed my MTU from 1500 to 1400, although I'm thinking of trying different numbers to see if that helps.

It's a strange thing, it doesn't seem to be a common problem. When playing PSOV1 and V2 a year or so ago, before I changed my router, it was downloading quests without freezing.

The only thing I can think of is that there might be an issue with my raspberry pi, or something to do with my new router.

Anyway, I'll probably experiment with a few things (I've got the time for it now!) to see if anything changes.

I'll let you guys know if it starts working again!

Re: PSO Quest Freeze Issue

Posted: Thu Sep 10, 2020 8:23 pm
by DreamState
Please see my post called UNSOLVED ISSUE. I’m having a similar problem.