VGA output issue, 480i instead of 480p

Technical help for Dreamcast console, accessories and games only. Ask questions and find answers here. For Online help see the Online Forum
Chael
lithium
Posts: 43

VGA output issue, 480i instead of 480p

Post#1 » Thu Feb 09, 2017 9:31 am

Hello guys, I have a weird problem, I believe undocumented so far.

After startup My DC + vga cable ouptut 480i for some reasons and I have to reboot the console several times until I get 480P.

When I first ot the cable it happened only occasionnaly so I didn't think much of it but know I have to reboot a lot of times to get 480p which is annoying.

It's not even a chinese cable but a homemade from Polish seller thefoo83 on ebay (Contacted him but he couldn't help).I didn't even know VGA could carry both 480i and 480P.

Do you think the problem is from the console or the cable?

I'm thinking it's more likely the console that detects something wrong, ss there a particular part inside the console that I could try to clean?
Or some stuff to check if I open the cable?

I don't have another cable or console to test with altough I'll eventually get the opportunity.

Not sur if this is relevant but I'm using the DC with a gdemu.

User avatar
SEGA RPG FAN
Graffiti Grind
Posts: 319

Re: VGA output issue, 480i instead of 480p

Post#2 » Thu Feb 09, 2017 10:01 am

The switch between 480i RGB, 480p RGB, and NTSC/PAL is done using the mode select pins on the AV out. http://www.gamesx.com/wiki/doku.php?id=av:dreamcastav
For 480p VGA, pins 6 and 7 need to be grounded. If you can, verify with a multimeter that they are indeed grounded. My guess is there is an intermittent connection somewhere, probably due to a less than great soldering job on the homemade cable. You could also try cleaning the contacts on the AV out port.
PSO Dreamcast 100% Legit: Eda FOmarl, Automaton HUcast

Chael
lithium
Posts: 43

Re: VGA output issue, 480i instead of 480p

Post#3 » Fri Feb 10, 2017 11:43 am

Thank you I'll look into it. Looks like it's not an easy fix :(
The seller seems reliable seems so I am quite unlucky if the soldering was poorly done.

About the AV port do you mean just cleaning the contacts from the outside? No need to unscrew everything to clean from motherboard side?

User avatar
SEGA RPG FAN
Graffiti Grind
Posts: 319

Re: VGA output issue, 480i instead of 480p

Post#4 » Fri Feb 10, 2017 12:27 pm

Chael wrote:About the AV port do you mean just cleaning the contacts from the outside? No need to unscrew everything to clean from motherboard side?
yes, just from the outside. You should be able to easily get a cotton swab with some isopropyl alcohol or other contact cleaner in the port.
PSO Dreamcast 100% Legit: Eda FOmarl, Automaton HUcast

  • Similar Topics
    Replies
    Views
    Last post

Return to “Support”

Who is online

Users browsing this forum: No registered users