DreamPi No Dial-tone Error

Technical help for Dreamcast console, accessories and games only. Ask questions and find answers here. For Online help see the Online Forum
User avatar
Posts: 1053

Re: DreamPi No Dial-tone Error

Post#11 » Fri May 10, 2019 3:12 pm

Hey codad, did you make your own lvi or get it from someone?

it's still thinking.

Posts: 6

Re: DreamPi No Dial-tone Error

Post#12 » Sat May 11, 2019 9:03 pm

I'm using this thread to share my own problem. I just received my rasberry pi kit today from pcwzrd13. I've had the no dial tone error and that has changed to No Carrier.

I should mention I don't have another dreamcast modem to test with and I don't have a multi-meter like support recommends.
What I do have:
I have two green lights on the USB modem and 1 red light on the raspberry pi.
Multiple phone cords that I have swapped and that has not made a difference
I have an Obi200 VOIP adapter, which provides a dial tone for my 2.4Ghz cordless phone. It essentially mimics an active phone line. I have used this to connect the dreamcast instead of the raspberry pi to test if my dreamcast modem is working. With this connection, the error is always, No Answer, No carrier.
I am using the Sega Dreamcast Web Browser (pretty sure it is the original, not 2.0). I do have Quake III somewhere if you think I should try that.

When I first started connecting, I had the no dial tone error immediately. Nothing I did seemed to change that.
Just recently, I configured the DMZ on my router and now the error I get is No Answer, No Carrier, which takes about 30 seconds.
I didn't think changing the DMZ would affect anything for the connection, but its now a different error.
I am using wifi and have not tried to use Ethernet yet.
The dreampi does show up on my network router with a good connection.

Web Browser Settings:

Dreampi dhcpcd error?

Obi200 connection test (no Dreampi involved)

Dreampi No Dial Tone Error

Dreampi No Answer, No Carrier

I'm not sure what to do now. I used to be a lot better at this 15 years ago...
I don't mind buying another LVI or DC modem to try and make it work.
Just wondering what the community thinks.

Thank you!

User avatar
Seen Any Sailors?
Posts: 6302

Re: DreamPi No Dial-tone Error

Post#13 » Sun May 12, 2019 8:08 am

Mertens wrote:I'm using this thread to share my own problem. I just received my rasberry pi kit today from pcwzrd13. I've had the no dial tone error and that has changed to No Carrier.

Sorry to hear about the issues. I'd be happy to check out the USB modem if you want to send it back to me. Just shoot me an email.
PSO Characters:
Teal'c - lvl 119 HUcast - GC# 11666
Alto - lvl 39 FOnewm - GC# 12964

YouTube Channel : Dreamcast Live

User avatar
Posts: 1343

Re: DreamPi No Dial-tone Error

Post#14 » Sun May 12, 2019 11:21 am

Blind dial should be on?

Posts: 6

Re: DreamPi No Dial-tone Error

Post#15 » Sun May 12, 2019 1:46 pm

mistamontiel wrote:Blind dial should be on?

I have toggled that back and forth. It either waits for a dial tone or not, but the error remains the same, that there is no dial tone.

I really wish I could plug in a regular phone and listen for a dial tone, because i did that and there was no sound out of the USB modem. Should there be?

pcwzrd13 wrote:Sorry to hear about the issues. I'd be happy to check out the USB modem if you want to send it back to me. Just shoot me an email.

I think I'll take you up on that. Thank you. It will be a few days before I can send it. I'm supposed to be studying for a professional certification on wednesday and i don't live near a convenient post office. So I should be able to send it later this week. I'll keep trying any new suggestions or ideas in the mean-time during my "study breaks." :D

Posts: 6

Re: DreamPi No Dial-tone Error

Post#16 » Fri May 24, 2019 8:47 pm

Just following up on my last post incase anyone else experiences this error.

I sent the USB modem back to pcwzrd13 and he confirmed a cable was loose. I got the cable back yesterday and told I was able to connect. THANK YOU VERY MUCH pcwzrd13 for taking a look and solving the problem.

At the moment, I've been able to connect to the starlancer server and host a game. This is the game I wanted to play online again.

I have been having a few connection issues. I'm not asking for help with these right now, I want to test what might be the issue. But just sharing for anyone else who might be experiencing the same thing.

My issues now are:
1 of the green lights on the USB modem is off sometimes, and on sometimes. If you had the USB cable on the right side, and the phone jack on the left side, it would be the top light that is intermittant. I believe this is an indicator of whether a connection is possible or not.
My first 5 minutes or so, that light was changing on and off like every 30 seconds or so. But then it calmed down. During that time I tried to connect with Dreamcast browser, and I got several new error messages I wasn't getting before. Seemed like connection was getting most of the way there, then dropped. The modem spat a bunch of jibberish at me but at least these were new messages.
I just decided to put starlancer in once it looked like the connection was stable. Starlancer did not connect the first time, but it did the second time. I'm testing how long i can stay in a game now. My first attemps timed out because i walked away from the game. oops.

At any rate, I'm happy its working :D and I'm going to test a few things out. Maybe its my wifi connection that isn't stable enough. I may switch to ethernet. Or perhaps my router was still integrating the pi into its settings for the first few minutes.

Thanks again for the support.

User avatar
Posts: 38

Re: DreamPi No Dial-tone Error

Post#17 » Sun Jun 09, 2019 4:15 pm

Some good tips that i found out for :!: PAL users :!: .
Did't find this anywhere else so thought I would share it.

My voltage inducer is 20V should be 18V but after getting No Dial-tone error, I measured it and found out it was high then 18V.
Strange (9Vx2 should be 18V) :lol: oWell. ( I have a NTSC jumper if I ever get a NTSC model)
So not enough power for the phone line, so that was not the problem :|

Next I used:

Code: Select all

sudo tail -f /var/log/syslog
To check syslog.
Rebooted the PI started a SSH connection from the moment that i could.
After that I noticed that I would get errors, the modem was not being recognized.

So what next, USB out and in! Then the modem would connect but Dreampi would go in shutdown mode and would 't restart afterwards.
So next test remove the line inducer until DreamPi was booted and modem got recognized. :mrgreen:
This is a good time to connect your line inducer.

just a test with Q3

And it works:

Next time I need to reboot my DreamPi I need to remove the Line inducer and wait i while before reconnecting it to the power.
If i follow these steps my Dreamcast gets online no problem otherwise Line busy error all the way.

Cheers Dcnigma
Check out my website http://dcnigma.eu5.org just a personal blog/website.
To keep track of my projects, Arcade Cabinets, Dreamcast mods, Raspberry Pi mods, Software, Design,
Homebrew Games, Rom Hacks, 3D prints, Strange things and many more :D :D :D

  • Similar Topics
    Last post

Return to “Support”

Who is online

Users browsing this forum: No registered users