Page 1 of 1

Video issue, black screen with intermittent video feed

Posted: Wed Oct 02, 2019 4:54 am
by Hytesta
Hello all, hoping that someone can help me here, I have searched for my issue but have not found any exactly like what I am experiencing.

So, a few weeks ago I found my old PAL Dreamcast in my ex-wife's loft, I'd had retrieved all the games and controllers, a couple of years ago but had not found the DC. Excitedly I got back to my house and plugged it in, eager to show my son 'Crazy taxi' and 'Shenmue'.

Got it all wired up, turned it on, power light came on, GDRom drive spun, sound worked but black screen! I waited, black screen, waited a bit more then for a brief second I saw the menu screen with the VMU bouncing, but it was short lived, back to black, waited a bit more and there again was the menu screen... and repeat.

So I do have a 98% working DC, but I have an issue with the video feed. I did a bit of research and decided it maybe down to the PSU so got a PicoPSU to replace it. Sadly this has not worked either so I was wondering if anyone knew of this problem and possible fixes? I am pretty competent with repairing things and not afraid to give things a go but that stops when it comes to repairing boards and soldering. I would rather get an expert involved at that stage.

Thanks in advance

Re: Video issue, black screen with intermittent video feed

Posted: Wed Oct 02, 2019 10:52 am
by aldair
Hytesta wrote:Hello all, hoping that someone can help me here, I have searched for my issue but have not found any exactly like what I am experiencing.

So, a few weeks ago I found my old PAL Dreamcast in my ex-wife's loft, I'd had retrieved all the games and controllers, a couple of years ago but had not found the DC. Excitedly I got back to my house and plugged it in, eager to show my son 'Crazy taxi' and 'Shenmue'.

Got it all wired up, turned it on, power light came on, GDRom drive spun, sound worked but black screen! I waited, black screen, waited a bit more then for a brief second I saw the menu screen with the VMU bouncing, but it was short lived, back to black, waited a bit more and there again was the menu screen... and repeat.

So I do have a 98% working DC, but I have an issue with the video feed. I did a bit of research and decided it maybe down to the PSU so got a PicoPSU to replace it. Sadly this has not worked either so I was wondering if anyone knew of this problem and possible fixes? I am pretty competent with repairing things and not afraid to give things a go but that stops when it comes to repairing boards and soldering. I would rather get an expert involved at that stage.

Thanks in advance

Did you check fan if it's working?

Re: Video issue, black screen with intermittent video feed

Posted: Wed Oct 02, 2019 10:55 am
by Hytesta
Yes, the fan is working as well, I can definitely hear it... fan upgrade also on the to do list if I can get the video signal fixed :)

Re: Video issue, black screen with intermittent video feed

Posted: Mon Nov 04, 2019 6:20 am
by Lorfarius
Check the HDMI cable. I've been having similar problems but swapping the lead worked for me.