Dreamcast Black Screen - No Audio or Video

Technical help for Dreamcast console, accessories and games only. Ask questions and find answers here. For Online help see the Online Forum
User avatar
Posts: 4

Dreamcast Black Screen - No Audio or Video

Post#1 » Sat May 02, 2020 7:11 am

Hi all,

I have a PAL early model Sega Dreamcast, which is unfortunately broke.

Symptoms: Black screen, no audio or video.

Troubleshooting: Tested on 2x televisions and computer monitor with AV in. Replaced CMOS battery.

Can anybody assist or point me in the right direction? I have a feeling I need to investigate AV output connector, but not sure where to start.

I am handy with tools and soldering.


User avatar
Ian Micheal
Posts: 2939

Re: Dreamcast Black Screen - No Audio or Video

Post#2 » Sat May 02, 2020 7:16 am

And your sure the av cable is working had many that dont.. does the light come on the dreamcast if you put a game in can you hear it reading it.. not very common to be dead with no video or audio..

Does the power light led come on? put a game see if it reading it for one.. might have a bad av cable or common not push in all the way because of a bent pin or crap

User avatar
Posts: 4

Re: Dreamcast Black Screen - No Audio or Video

Post#3 » Sat May 02, 2020 7:30 am

Hi Ian,

Yeah light comes on, game spins up, VMU beeps *and remains feint grey*.

I have not yet tried a different cable, but am a bit doubtful that could be it as they're not common to break..

Have opened up the unit before and given it a clean out using a cloth and recently compressed air spray.
Last edited by thegonzo on Mon May 04, 2020 8:35 pm, edited 1 time in total.

User avatar
Posts: 4

Re: Dreamcast Black Screen - No Audio or Video

Post#4 » Mon May 04, 2020 8:33 pm

Hi guys,

I've performed further testing lastnight and here is a clarification of symptoms:
-Device powers on, orange light on, can hear the device working albeit quite loud.
-VMU connected to the controller chimes at launch and when reconnecting the controller to port.
-VMU does not display anything subsequently, remains a faint grey screen.
-Have tried to navigate blindly with a game inside the unit, pressing <- and A (initial date/time setup), but VMU still lacks output.
-Game disk spins, as noticeable when opening lid.

I am guessing this could be a mobo or PSU fault? If the prior, is it worth fixing?

Recently procured a multimeter from JayCar, happy to test any circuitry if I can be provided with guidance?

Appreciate any suggestions :)

  • Similar Topics
    Last post

Return to “Support”

Who is online

Users browsing this forum: No registered users