Strange sound problems on my new Dreamcast

Technical help for Dreamcast console, accessories and games only. Ask questions and find answers here. For Online help see the Online Forum
BertieWooster
noob
Posts: 4

Strange sound problems on my new Dreamcast

Post by BertieWooster »

I got my first Dreamcast in the post today, but I've been plagued with problems with the sound.

Basically, games load but there is no sound at all. No CD audio, no sound effects, nothing. Oddly, I do get sound (albeit horrible, crunchy sound) when I use discs made with the Amiga emulator. I'm used to Amiga audio, and this doesn't sound right! But I don't know if that's the emulation, or a fault.

Normal audio CDs won't play either. Or rather, they play, but there's no audio. No sound at all.

I've tried it using a Kaico HDMI adaptor on my LCD TV, and with a scart cable connected to my B&O CRT TV. I get the same problems on both TVs, so the AV cable can't be to blame. I've given the AV connector a quick clean, to no avail.

It's one of those things where I'm wondering if I'm going mad - it seems odd that the Amiga emulator produces (poor) sound but no games or CDs do. Any suggestions would be much appreciated.

User avatar
Ian Micheal
Developer
Posts: 6082
Location: USA
Contact:

Re: Strange sound problems on my new Dreamcast

Post by Ian Micheal »

Not getting sound on the bios menu or in cd player there is problem.. no not crunchy sounds on amiga emulator something else is a problem here.. Got no sound effects in the bios menu..

plug in and out the cable check again .. Never herd of this problem before i have 8 dreamcasts..

BertieWooster
noob
Posts: 4

Re: Strange sound problems on my new Dreamcast

Post by BertieWooster »

Thanks, that's what I thought. No sound at all in the menus. I've tried everything, so I suppose it's going back :(
Ian Micheal wrote:Not getting sound on the bios menu or in cd player there is problem.. no not crunchy sounds on amiga emulator something else is a problem here.. Got no sound effects in the bios menu..

plug in and out the cable check again .. Never herd of this problem before i have 8 dreamcasts..

  • Similar Topics
    Replies
    Views
    Last post